Geheimnis

Author Topic: Hang in the lost library - how to install the 1.0.1 linux version  (Read 1413 times)

thorfdbg

  • Newbie
  • *
  • Posts: 3
    • View Profile
Hi folks,

just bought the boxed version of bout2 and installed it under Linux (Debian stable). Runs (almost) without problems - however, there seems to be a game bug in the lost library. When Wilbur ignites the fire from the desk drawer, the game no longer continues and I cannot perform any other activities. Has this been fixed?

There seems to be a 1.0.1. version as a patch on your download side. However, how do I install it, and where do I need to place all the files? I tried to manually copy them over the similarly named files of the 1.0.0 version, but then nothing works anymore:

thor@dewshine:~/bout2/Linux> ./BouT2.x86_64
Set current directory to /home/thor/bout2/Linux
Found path: /home/thor/bout2/Linux/BouT2.x86_64
Mono path[0] = '/home/thor/bout2/Linux/BouT2_Data/Managed'
Mono path[1] = '/home/thor/bout2/Linux/BouT2_Data/Mono'
Mono config path = '/home/thor/bout2/Linux/BouT2_Data/Mono/etc'
PlayerInitEngineNoGraphics settings: Could..... not preload global game manager #0   i=0
Failed to initialize player

Neither can I install it by the "Launcher" since the Launcher itself does not work:

thor@dewshine:~/bout2/launcher/1.0.0> ./Launcher
./Launcher: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by ./Launcher)
./Launcher: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by ./lib/libqjsonrpc.so.1)
./Launcher: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by ./lib/libquazip.so.1)

Note that this is a debian stable, it comes with a glibc 2.13, not with a glibc 2.14 (and no, I'm not trying to mess with this system by moving to "testing" just to install a glibc 2.14 - that's not an option).

Hence, what can I do?


thorfdbg

  • Newbie
  • *
  • Posts: 3
    • View Profile
Since none of the Kingart developers seem to bother (what is this forum? Some kind of an alibi function)? here is my own response for all those that run into the same trouble.

Do *not* attempt to download the version for "self-updating" for the DVD-version. That simply does not work. Probably it's broken, or for some other distribution.

Instead, the following work-around did the job for me:

a) create a new virtual machine with VMware, install an old windows on it. Windows XP is nice enough. At this time, do not bother about the limited graphics capabilities of WMware, not relevant.

b) Install bout2 from the DVD into the virtual machine.

c) Start it. It will ask you whether you want to check for a new release. Answer "yes".

d) When asked whether to launch the game, say "no". VMware is (unless 3D emulation is available) too slow to be useful.

e) Mount a net-drive to a part of the host filing system.

f) Copy everything from the "Data" directory of the "Bout2"-directory in C:Programs to the net-mount.

g) Copy on the Linux side everything from the target of the net-mount, i.e. all the files below "Data" onto the very same files of the Linux installation of bout2.

h) Do not attempt to use the "Launcher" on debian. Apparently, folks either at Steam or at King-Art did not consider that Debian comes with an older release of glibc. Instead, start the game directly. It is in the "Linux" directory. Pick either the 32 bit or 64-bit version.

Voila, deadlock in the library solved...